Monitoring Stabilitas Link Dengan Fasilitas Netwatch

Backup from: http://priyo.datautama.net.id

Tutorial sederhana berikut akan membahas bagaimana memonitor stabilitas link internet ke ISP / ke client anda. Berangkat dari kebutuhan monitoring DataUtamaNet  yang benar-benar real time untuk kualitas redundancy Fiber Optic XL  & Icon+ dari Semarang – Jakarta maka saya coba utik2 Mikrotik dan menemukan trik ini. Semoga dapat bermanfaat buat semua.

Here we go ..

Langkah pertama

Kita akan memanfaatkan fasilitas Netwatch dari Mikrotik dengan mengetikan perintah :

/tool netwatch add host=203.89.24.1 timeout=1 interval=00:00:01 down-script=LINKUP up-script=LINKDOWN

Dengan perintah diatas maka mikrotik akan menjalangkan ping ke host 203.89.24.1 ( ip dari server yang dituju ) intervalnya adalah 1 detik , time out 1 detik dan akan menjalankan script LINKDOWN ketika host tidak bisa di ping ( Request Time Out )

Dan begitu host sudah ping reply lagi maka script LINKUP yang akan dijalankan

Langkah ke dua

Membuat adonan scriptnya, ketikan command :

/system script add name=LINKDOWN source={/tool e-mail send subject=(”LINK DOWN ” . [/system clock get date] . ” ” . [/system clock get time]) from=alert@datautama.net.id server=203.89.24.4 to=priyo@datautama.net.id”}; :log info “LINK DOWN

/system script add name=LINKUP source={/tool e-mail send subject=(”LINK UP ” . [/system clock get date] . ” ” . [/system clock get time]) from=alert@datautama.net.id server=203.89.24.4 to=priyo@datautama.net.id”} ; :log info “LINK UP

Fungsi dari script diatas adalah melakukan pengiriman email ke kita dengan subject email adalah variable hari dan jam link itu down atau up kembali, dimana script di trigger oleh netwatch.

Dengan prinsip kerja yang sama kita bisa melakukan banyak modifikasi script untuk kepentingan lain seperti fail over gateway atau yang lain, manfaatkan imajinasi anda :)

Tutorial ini akan lebih bermanfaat jika anda berlangganan Push Email menggunakan BlackBerry sehingga email bisa real time masuk ke Handphone anda. Tapi saran saya jangan lakukan !! Anda tidak mau kan ketika sedang asyik menonton bioskop dengan pacar ( atau selingkuhan :) ) dan dapat sms link Backbone anda DOWN ?? ( Hahaha .. bukan pengalaman pribadi penulis lho … :P )

Selamat mencoba

Thanks to : Mikrotik Expert ( Harijanto Pribadi )

One response to “Monitoring Stabilitas Link Dengan Fasilitas Netwatch

  1. Mas mohon bantuan untuk scrip disable dan enable.
    jika ping ip tujuan RTO. Kasus ya saama cma langkah kedua ya
    scrip untuk disable / enable interface

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s